HDU 2700

Parity

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4334    Accepted Submission(s): 3264


Problem Description

A bit string hasodd parity if the number of 1's is odd. A bit string has even parity if thenumber of 1's is even.Zero is considered to be an even number, so a bit stringwith no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.

 

 

Input

The input consistsof one or more strings, each on a line by itself, followed by a line containingonly "#" that signals the end of the input. Each string contains 1–31bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.

 

 

Output

Each line ofoutput must look just like the corresponding line of input, except that theletter at the end is replaced by the correct bit so that the entire bit stringhas even parity (if the letter was 'e') or odd parity (if the letter was 'o').

 

 

Sample Input

101e

010010o

1e

000e

110100101o

#

 

 

Sample Output

1010

0100101

11

0000

1101001010

 

题意简述

看字符串中1的个数,e结尾变成偶数,o结尾变成单数

题意分析

明白了就是水题

 

代码总览

#include<stdio.h>
#include<string.h>
int main()
{
	//freopen("in.txt","r",stdin);
	int length,i,count;
	char str[101] ;
	while(scanf("%s",str) != EOF && str[0] != '#'){
		count = 0;
		length = strlen(str);
		for(i = 0; i<length-1;i++){
			if(str[i]=='1'){
				count++;
			} 
		}
		if(count%2==0 && str[length-1] == 'e'){
			str[length-1]='0';
		}else if(count%2!=0 && str[length-1] == 'e'){
			str[length-1]='1';
		}else if(count%2==0 && str[length-1] == 'o'){
			str[length-1]='1';
		}else if(count%2!=0 && str[length-1] == 'o'){
			str[length-1]='0';
		}
		for(i = 0; i<length;i++){
			printf("%c",str[i]);
			if(i == length-1){
				printf("\n");
			}
		}
	}
	return 0;
	//fclose(stdin);
}

谢谢您耐心的看完本文!

 

我是ACM小白,希望与诸君共勉!欢迎收听新浪微博:鹏威尔Will


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值