hdu 2700 Parity

Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.


Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.



Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').


Sample Input
101e
010010o
1e
000e
110100101o
#


Sample Output
1010
0100101
11
0000

1101001010

我也没大看懂啥意思,直接看数据,找规律,然后竟然ac了

规律是一个字符串中1的数量如果是奇数的话,并且最后一位是e的话,就把e换成1,如果是o的话就换成0;

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
  char c[35];
  int len,i,count;
    while(~scanf("%s",c))
    {
        if(c[0]=='#') break;
        len=strlen(c);
        count=0;
    for(i=0;i<len-1;i++)
        {
            if(c[i]=='1')
                count++;
        }
            if((count%2==0&&c[len-1]=='e')||(count%2==1&&c[len-1]=='o'))
                        c[len-1]='0';
                else c[len-1]='1';
            puts(c);
    }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值