poj 3041 Asteroids

题目链接:点击打开链接

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
题目大意:给一个N*N的矩阵,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,
最少要几次。这里将每行x看成一个X结点,每列Y看成一个Y结点,障碍的坐标x,y看成X到Y的
一条边,
基本思路:构建出图后,就变成了找最少的点,使得这些点与所有的边相邻,即最小点覆盖问题。
裸的匈牙利算法…
最小点覆盖==二分图的最大匹配数
<span style="font-size:18px;">#include <iostream>
#include<cstring>
using namespace std;
int mp[1000][1000];
int vis[1000];
int link[1000];
int n;
int dfs(int t)
{
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==0&&mp[t][i])
        {
            vis[i]=1;//标记哦
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=t;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
   int k;
   cin>>n>>k;
   int x,y;
   memset(mp,0,sizeof(mp));
   for(int i=0;i<k;i++)
   {
       cin>>x>>y;
       mp[x][y]=1;
   }
   int num=0;
   memset(link,-1,sizeof(link));
   for(int i=1;i<=n;i++)
   {
       memset(vis,0,sizeof(vis));
       if(dfs(i))num++;
   }
   cout<<num<<endl;
    return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值