PAT 1038. Recover the Smallest Number (30)

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

这道题主要就是要写个cmp函数。要注意的是,在这道题中类似于”321"和“32”的比较中,"321"才是较小的那一方。

代码如下:

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
bool cmp(string a,string b)
{
	int sizeA=a.size();
	int sizeB=b.size();
	if(a<b&&sizeA>=sizeB)
		return true;
	else if(a<b&&sizeA<sizeB)
	{
		if(a==b.substr(0,sizeA))
		{
			int i;
			for(i=sizeA;i<sizeB;i++)
				if(b[i]>a[0])
					break;
			if(i>sizeA)
				return false;
			else
				return true;
		}
		else
			return true;
	}
	else if(a>b&&sizeA<=sizeB)
		return false;
	else if(a>b&&sizeA>sizeB)
	{
		if(b==a.substr(0,sizeB))
		{
			int i;
			for(i=sizeB;i<sizeA;i++)
				if(a[i]>b[0])
					break;
			if(i>sizeB)
				return true;
			else
				return false;
		}
		else
			return false;
	}
	
}
int main(void)
{
	int N;
	cin>>N;
	vector<string> result;
	while(N--)
	{
		string temp;
		cin>>temp;
		result.push_back(temp);
	}
	vector<string>::iterator it;
	sort(result.begin(),result.end(),cmp);
	int flag=0;
	for(it=result.begin();it!=result.end();it++)
	{
		if(flag==0)
		{
			int n=atoi((*it).c_str());
			if(n==0)
				continue;
			else
			{
				cout<<n;
				flag=1;
			}
		}
		else
			cout<<*it;
	}
	if(flag==0)
		cout<<0;
}	


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值