PAT 1059. Prime Factors (25)

1059. Prime Factors (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

这道题是分解质因数问题。输入正整数N,将其拆分为质数乘积。我的做法是一开始先找到所有从2到根号N内的质数,然后依次试除这些数并计数,然后按照要求的格式输出就行了。代码如下:

#include <iostream>
#include <cmath>
using namespace std;
int prime[100000];
bool judge(long int x)
{
	if(x==2)
		return true;
	int i;
	for(i=2;i<=sqrt(x);i++)
		if(x%i==0)
			break;
	if(i>sqrt(x))
		return true;
	else
		return false;
}
int getprime(long int n)
{
	long int i;
	int j=0;
	for(i=2;i<=sqrt(n);i++)
		if(judge(i))
			prime[j++]=i;
	return j;
}
int main()
{
	long int N;
	cin>>N;
	long int n=N;
	int size=getprime(N);
	cout<<N<<"=";
	if(judge(N))
	{
		cout<<N;
		return 0;
	}
	for(int i=0;i<size;i++)
	{
		int count=0;
		for(;n%prime[i]==0;)
		{
			n/=prime[i];
			count++;
		}
		if(judge(n))
		{
			if(n>=2)
			{
				if(count==1)
					cout<<prime[i]<<"*"<<n;
				else if(count>1)
					cout<<prime[i]<<"^"<<count<<"*"<<n;
			}
			else
			{
				if(count==1)
					cout<<prime[i];
				else if(count>1)
					cout<<prime[i]<<"^"<<count;
			}
			break;
		}
		if(count==1)
			cout<<prime[i]<<"*";
		else if(count>1)
			cout<<prime[i]<<"^"<<count<<"*";

	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值