hdu 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25144    Accepted Submission(s): 11229


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
#define max 100

int v[max];
int a[max];
int vis[max];
int i,n;

void dfs(int cur)
{
	if(cur==n && v[a[0]+a[n-1]])  //递归边界,测试第一个数和最后一个数。
	{
		for(i=0;i<n;i++)
		{
			if(i!=n-1) printf("%d ",a[i]);    //注意格式问题
			else printf("%d\n",a[i]);
		}
	}
	else
	{
		for(int i=2;i<=n;i++)                // 尝试放每一个数i
			if(!vis[i]&&v[i+a[cur-1]])       // 如果i没有用过,并且与前一个数之和为素数
			{
				a[cur]=i;    // i满足条件,则放入到数组a中
				vis[i]=1;    // 设置标记
				dfs(cur+1);
				vis[i]=0;    // 清除标记
			}
	}
}

int isprime(int n)   // 素数打表
{
	int k=1;
	for(int i=2;i<n/2;i++)
	{
		if(n%i==0)
			k=0;
	}
	return k;
}



int main()
{	
   int  p=1;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=2*n;i++)
			v[i]=isprime(i);  //判断 1 到 2*n 中哪些是素数(若是素数则赋值为1)。v[2]=0,v[7]=1.....
		for(i=0;i<n;i++)
			a[i]=i+1;          //将数 1 到 n 存到数组a里面。 a[0]=1,a[1]=2,a[2]=3,a[3]=4......
		printf("Case %d:\n",p);
		dfs(1);
		p++;
		printf("\n");
	}
	return 0;
}


 
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值