POJ3186:Treats for the Cows

Treats for the Cows
Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input

5
1
3
1
5
2
Sample Output

43
Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

题意: 
给定n个元素的序列 , 每次从双端取元素 ,天数+1 (1->n) 。 求最大sell总和 。

状态转移方程 dp[L][R] = max( dp[L+1][R] + init[L](n-len) , dp[L][R-1] + init[R](n-len) 
init[maxn] 元素数组 ; 
L 左端 , R 右端 , len 区间长度(R-L)

#include <iostream>
#include <cstdio>
#include <cstring>
const int maxn = 2000 + 10 ;
int dp[maxn][maxn] , init[maxn] ;
using namespace std;
int main() {
    int  n ;
    while(cin >> n){
            memset(init , 0 , sizeof(init)) ;
        for(int i = 0 ; i < n ; ++i ) {
            scanf("%d",&init[i]);
            dp[i][i] = n*init[i] ;                        //初始化对角线为最后sell  , 假设每个都是元素都是最后sell
        }
        for ( int len =  1 ; len < n ; ++len) {           //区间宽度  
            for ( int L  = 0 ; L + len < n ; ++L ) {      //左端取值范围(0,n-len)
                int R = L + len ;                         //右端取值为 L + len 
                dp[L][R] = max( dp[L+1][R] + init[L]*(n-len) , dp[L][R-1] + init[R]*(n-len) ); 
            }                //(L+1,R)的最大值  + 取左端元素    ; (L,R-1)最大值 + 取右端元素                                       
        }                    // 从最后sold的往前推  
        printf("%d\n",dp[0][n-1]) ;  // (0,n-1)即为最大值
    }
    return 0 ;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值