POJ 1426 Find The Multiple

Find The Multiple
Time Limit: 1000MS 
Memory Limit: 10000K


Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
Source
Dhaka 2002
题意: 给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m只由十进制的'0'或'1'组成。
简单宽搜 简单深搜
BFS代码

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std ;
long long n ;
void bfs() {
    queue <long long> Q ;
    while(!Q.empty()){
        Q.pop() ;
    }
    Q.push(1) ;
    while(!Q.empty()) {
        long long ans = Q.front();
        Q.pop() ;
        if( ans >= n && ans%n == 0 ) {
            printf("%lld\n",ans) ;
            break ;
        }
        else {
            Q.push(ans*10) ;
            Q.push(ans*10+1) ;
        }
    }
}
int main(){
        while(~scanf("%d",&n)&&n){
            bfs() ;
        }
    return 0 ;
}

DFS代码
#include <iostream>
#include <cstdio>
using namespace std ;
long long  temp , n ;
int time = 0 ;
bool flag ;
bool dfs(long long  temp ) {
    if( temp >1222222222222222222 || temp <0)  // 范围是网上找的....
        return  false ;
        if(  temp >= n && temp%n == 0 ) {
            printf("%lld\n",temp) ;
            return  true ;
        }
        if(dfs( temp*10) ) return true ;
//        printf("%d %I64d\n" ,++time , temp*10 ) ;
        if(dfs( temp*10+1) ) return true ;
//         printf("%d %I64d\n" ,++time , temp*10+1 ) ;
        return false ;
}

int main() {
    while(~scanf("%lld",&n)&&n) {
            flag = true ;
         dfs(1)  ;
    }
    return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值