Sigma Function LightOJ - 1336

题目链接:https://vjudge.net/problem/LightOJ-1336
Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is
在这里插入图片描述
Then we can write,
在这里插入图片描述For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4
3
10
100
1000

Sample Output

Case 1: 1
Case 2: 5
Case 3: 83
Case 4: 947
思路:对于任意一个x, 都有x = p1^a1 p2a2*…*pnan;
所以x的因子和 f(x)= (1+p1+p12+p13+…+p1a1)*(1+p2+p2 2+…+p2a2)*…*(1+pn+pn 2 +…+pn^an);
我们已知只有奇数乘奇数才会是奇数,又因为
在这里插入图片描述我们可以知道2^ x次方减一一定是奇数, σ(任意数的平方)一定也是个奇数,σ(任意数的平方×2的任意次方)也一定是奇数,所以,最后只用减去 2 ^ x,x^ 2和2
x^ 2,x^ 2和2x ^ 2又包含2^ x,所用只用减去x^ 2和2x^2.

代码:

#include <bits/stdc++.h>

using namespace std;


int main()
{
    int t;
    int Case=1;
    scanf("%d",&t);

    while(t--)
    {
        long long int n;
        scanf("%lld",&n);
        long long int num=n;
        num-=(int)sqrt(n);
        num-=(int)sqrt(n/2);
        printf("Case %d: %lld\n",Case++,num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值