C - Car HDU - 5935

Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record N positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 00.

Now they want to know the minimum time that Ruins used to pass the last position.
Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with an integers N, which is the number of the recorded positions.

The second line contains N numbers a1a1, a2a2, ⋯⋯, aN, indicating the recorded positions.

Limits
1≤T≤1001≤T≤100
1≤N≤1051≤N≤105
0<ai≤10^9 0<ai≤10 ^ 9
ai<ai+1ai<ai+1
Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum time.
Sample Input
1
3
6 11 21
Sample Output
Case #1: 4
思路很简单,从后往前遍历,一开始的速度等于最后一段距离的长度,前面的速度要小于等于后面的速度
最主要的是精度问题,这里用的是eps
EPS 是MATLAB中的函数,表示浮点相对精度。 [1] 对双精度数值来说eps表示从 1.0 到下一个最大双精度数的距离。对单精度数值来说eps表示从 1.0 到下一个最大单精度数的距离。
来源百度百科:https://baike.baidu.com/item/EPS/10928325?fr=aladdin

也可以用分数来表示,别人的代码:https://blog.csdn.net/f_zyj/article/details/78259523
ac代码:

#include <bits/stdc++.h>

using namespace std;
#define eps (1e-8)//代码重点
double v;
int main()
{
    int t;
    int Case=1;
    cin>>t;
    while(t--)
    {
       int n;
       cin>>n;
       long long int a[100001];
       int i;
       for(i=1;i<=n;i++)
       {
          scanf("%lld",&a[i]);
       }
       a[0]=0;
       long long int sum=1;
       v=a[n]-a[n-1];
       for(i=n-2;i>=0;i--)
       {
          long long int x=a[i+1]-a[i];
          if(x<=v+eps)
          {
             v=x;
             sum++;
          }
          else
          {
             long long int t=ceil((double)(x-eps)/v);
             sum+=t;
             v=(double)(x*1.0/t);
          }
       }
       printf("Case #%d: %lld\n",Case++,sum);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值