H - Piggy-Bank (动态规划)(完全背包问题)

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
 
 
 
 
嗯 刚开始其实不是很喜欢每次写完题目上博客 后来其实觉得上博客发表下其实真的很不错 一方面可以把自己做过的题目给手收集起来即便以后不会经常看 但是也有需要看的时候  还有一方面把就是感觉每次写博客就好像在重温做题的一个过程一样~~~~~~~~~·
嗯  这题刚开始一直wa一直没搞懂为什么     结果我靠发现是自己给dp的初始化太小了 可是其实我根本不知道为什么太小了会这样子有一点点的奇怪
以后只能尽量往大的去了  感觉就是这个样子木有了 是一道完全背包的题目自己也不是很熟就是半推半就的做
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 999999999
int value[505];
int weight[505];
int dp[10005];//dp最后存的是价值 
int main()
{
	int t;
	scanf("%d",&t);
	int n,m,total;
    while(t--)
{
  scanf("%d%d",&n,&m);
  int total=m-n;
  int g;
  scanf("%d",&g);
  for(int i=1;i<=total;i++)
  dp[i]=INF;
  dp[0]=0;
  for(int i=1;i<=g;i++)
  scanf("%d%d",&value[i],&weight[i]); 
  if(total<=0)
  {
  	printf("This is impossible.\n");
  	continue;
  }
  for(int i=1;i<=g;i++)
  {
  	  for(int j=weight[i];j<=total;j++)
  	  {
  	  	  dp[j]=min(dp[j],dp[j-weight[i]]+value[i]);
	  }
  }
  if(dp[total]==INF)
  printf("This is impossible.\n");
  else 
  printf("The minimum amount of money in the piggy-bank is %d.\n",dp[total]);
}
	return 0;
} 

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值