Piggy-Bank-完全背包问题

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2940    Accepted Submission(s): 1452

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

 

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.

大概意思就是:有一个存钱罐,告知你其空时的重量和当前重量,并给定一些钱币的价值和相应的重量,问存钱罐中最少有多少现金?
思路:由于每个钱币都可以有任意多,所以该问题为完全背包问题,要求我们在状态转移时,在dp[j]和dp[j-list[i].w]+list[i].v]中选择一个较小的作为值,其次,要求钱币重量和空余的重量要恰好达到总重量。
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
#define INF 0x7fffffff
struct E{
	int w,v;
}list[500];

int dp[1001];

int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		int s,tmp;
		scanf("%d%d",&tmp,&s);
		s-=tmp; //计算差额重量,也就是钱币的重量
		int num;
		scanf("%d",&num);
		for(int i=1;i<=num;i++){
			scanf("%d%d",&list[i].v,&list[i].w);
		}
		for(int i=1;i<=s;i++) //因为要求刚好装满,所以其他的取不到都赋值为无穷
			dp[i]=INF;
		dp[0]=0;
		for(int i=1;i<=num;i++)//完全背包。顺序遍历所以可能转移的状态
			for(int j=list[i].w;j<=s;j++){ 
				if(dp[j-list[i].w]!=INF) //若不为负无穷,就是说这个可以取到
				dp[j]=min(dp[j],dp[j-list[i].w]+list[i].v);
			}
		if(dp[s]!=INF) //存在就输出
		   printf("The mininim amount of money in the piggy-bank is %d\n",dp[s]);
		else
			printf("This is impossible!");
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值