poj2975,hdu1850,hdu2176(Nim博弈求方案数)

poj2975,hdu1850

地址:http://poj.org/problem?id=2975

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1850

Nim
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4043 Accepted: 1874

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removingone or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1,k2, …,kn stones respectively; in such a position, there arek1 +k2 + … + kn possible moves. We write eachki in binary (base 2). Then, the Nim position is losing if and only if, among all theki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if thexor of theki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, supposek3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move whenk1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤n ≤ 1000. On the next line, there are n positive integers, 1 ≤ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case withn = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

题意:求必胜的方案有多少种(只走一步)。

利用Nim博弈以及异或运算。

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
int main()
{
	int m,n,a[1010],i;
	while(scanf("%d",&m)>0,m)
	{
		for(i=1;i<=m;i++)
			scanf("%d",&a[i]);
		n=a[1];
		for(i=2;i<=m;i++)
			n^=a[i];  //这里是nim博弈后的得到的值
		if(n==0) printf("0\n");
		else
		{
			int sum=0;
			for(i=1;i<=m;i++)
				if((n^a[i])<=a[i])  //让这个值与每一堆石子异或运算,若得到的结果小于本堆石子数,那么就表明可以去掉这么多的石子,是的异或运算的结果变为0
					sum++;          //也就是走一步让必胜态变为必败态
			printf("%d\n",sum);
		}
	}
	return 0;
}


 

hdu2176

地址:http://acm.hdu.edu.cn/showproblem.php?pid=2176

取(m堆)石子游戏

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1090    Accepted Submission(s): 646


Problem Description

 

m堆石子,两人轮流取.只能在1堆中取.取完者胜.先取者负输出No.先取者胜输出Yes,然后输出怎样取子.例如5堆 5,7,8,9,10先取者胜,先取者第1次取时可以从有8个的那一堆取走7个剩下1个,也可以从有9个的中那一堆取走9个剩下0个,也可以从有10个的中那一堆取走7个剩下3个.
 


 

Input

 

输入有多组.每组第1行是m,m<=200000. 后面m个非零正整数.m=0退出.
 


 

Output

 

先取者负输出No.先取者胜输出Yes,然后输出先取者第1次取子的所有方法.如果从有a个石子的堆中取若干个后剩下b个后会胜就输出a b.参看Sample Output.
 


 

Sample Input

 

  
  
2 45 45 3 3 6 9 5 5 7 8 9 10 0
 


 

Sample Output

 

  
  
No Yes 9 5 Yes 8 1 9 0 10 3
 


 

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
int a[200010],b[200010],c[200010];
int main()
{
	int m,i,ans,tp;
	while(scanf("%d",&m)>0,m)
	{
		ans=0;tp=0;
		for(i=1;i<=m;i++)
		{
			scanf("%d",&a[i]);
			ans^=a[i];
		}
		if(ans==0) 
		{
			puts("No");
			continue;
		}
		for(i=1;i<=m;i++)
		{
			if((ans^a[i])<=a[i])
			{
				b[tp]=a[i];
				c[tp++]=(ans^a[i]);
			}
		}
		puts("Yes");
		for(i=0;i<tp;i++)
			printf("%d %d\n",b[i],c[i]);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值