133 - The Dole Queue

In a serious attempt to downsize (reduce) thedole queue, The New National Green Labor Rhinoceros Party has decided on thefollowing strategy. Every day all dole applicants will be placed in a largecircle, facing inwards. Someone is arbitrarily chosen as number 1, and the restare numbered counter-clockwise up to N (who will be standing on 1's left).Starting from 1 and moving counter-clockwise, one labour official counts off kapplicants, while another official starts from N and moves clockwise, countingm applicants. The two who are chosen are then sent off for retraining; if bothofficials pick the same person she (he) is sent off to become a politician.Each official then starts counting again at the next available person and theprocess continues until no-one is left. Note that the two victims (sorry,trainees) leave the ring simultaneously, so it is possible for one official tocount a person already selected by the other official.

Input

Write a program that will successively readin (in that order) the three numbers (N, k and m; k, m > 0, 0 < N <20) and determine the order in which the applicants are sent off forretraining. Each set of three numbers will be on a separate line and the end ofdata will be signaled by three zeroes (0 0 0).

Output

For each triplet, output a single line ofnumbers specifying the order in which people are chosen. Each number should bein a field of 3 characters. For pairs of numbers list the person chosen by thecounter-clockwise official first. Separate successive pairs (or singletons) bycommas (but there should not be a trailing comma).

Sample input

10 4 3

0 0 0

Sample output

 4  8,  9  5,  3  1,  2  6,  10,  7

where  representsa space.

方法一(麻烦但是好想):

#include<iostream>

#include<iomanip>

using namespace std;

int num[30];

int main()

{

   int n,k,m;

   while(cin>>n>>k>>m&&n)

   {

       for(int i=0;i<n;i++)

       {

           num[i]=i+1;

       }

       int left=n;

       int a=0,b=n-1+100*n;//防止产生负数

       while(left)

       {

           int flag1=0,flag2=0;

           for(; ;a++)

           {

                if(num[a%n])

               {

                    flag1++;

                }

                if(flag1==k)

                {

                   cout<<setw(3)<<num[a%n];//逆时针优先

                    left--;

                    break;

                }

           }

           for(;;b--)

           {

                if(num[b%n])

                {

                    flag2++;

                }

                if(flag2==m)

                {

                    if(num[b%n]!=num[a%n])

                    {

                        cout<<setw(3)<<num[b%n];

                        left--;

                        break;

                    }

                    break;

                }

           }

           if(left)

           {

                cout<<",";

           }

           else

           {

                cout<<endl;

           }

           num[b%n]=0;

           num[a%n]=0;

       }

   }

}

方法二:(精简但是不好想)

#include<iostream>

#include<iomanip>//输出宽度控制

using namespace std;

int n,k,m;

int num[30];//存连续正整数的数组

int run(int pos,int add,int sum);//当前位置,每次移动的增量,需要移动的总次数

int main()

{

   while(cin>>n>>k>>m&&n!=0)

   {

       for(int i=1;i<=n;i++)

       {

           num[i]=i;

       }

       int acwp=0,cwp=n+1;// acwp:逆时针查数的前一个未知的索引;

//cwp:顺时针查数的后一个位置的索引

       int left=n;//总的数字中未被查到的数字的个数

       while(left)

       {

           acwp=run(acwp,1,k);//逆时针查数

           cwp=run(cwp,-1,m);//顺时针查数

           num[acwp]=0;//题意为优先逆时针(当顺逆均查到同一位置时)

           left--;//未被查到的数字减少一个

           cout<<setw(3)<<acwp;//优先输出

           if(acwp!=cwp)//只有当顺逆查到的数字不相同时才对顺时针进行输出

           {

                left--;

                num[cwp]=0;

                cout<<setw(3)<<cwp;

           }

           if(left)//当还有数字没查时,输出逗号

           {

                cout<<",";

           }

       }

       cout<<endl;//每测试完一组数据,输出换行

   }

}

int run(int pos,int add,int sum)

{

   while(sum--)//写成--sum就循环少了一次

   {

       do

       {

           pos=(pos+add+n-1)%n+1;//统一了移动是向前还是向后的操作;从N变成1好理解;从1变成N这样理解:向后退一个单位相当于向前走了N-1个单位

      }

       while(num[pos]==0);//只要下一个位置被查到过(==0),就继续向下查找,直到查到的数字不为0

   }

   return pos;//返回索引

}

 

用C++编写程序,实现以下问题2、题目ID Codes(POJ1146) Time Limit: 1000MS Memory Limit: 10000K 描述: It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 of b' and 1 of c', then three of the allowable 60 codes under these conditions are: abaabc abaacb ababac These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message No Successor' if the given code is the last in the sequence for that set of characters. 输入: Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. 输出: Output will consist of one line for each code read containing the successor code or the words 'No Successor'. 样例输入 abaacb cbbaa # 样例输出 ababac No Successor
最新发布
05-22
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值