10474 - Where is the Marble

Raju and Meena love to play with Marbles.They have got a lot of marbles with numbers written on them. At the beginning,Raju would place the marbles one after another in ascending order of thenumbers written on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one point forcorrect answer, and Meena gets the point if Raju fails. After some fixed numberof trials the game ends and the player with maximum points wins. Today it's yourchance to play as Raju. Being the smart kid, you'd be taking the favor of acomputer. But don't underestimate Meena, she had written a program to keeptrack how much time you're taking to give all the answers. So now you have towrite a program, which will help you in your role as Raju.

Input 

There can be multiple test cases. Total no oftest cases is less than 65. Each test case consists begins with 2integers: N the number of marbles and Q thenumber of queries Mina would make. The next N lines wouldcontain the numbers written on the N marbles. These marblenumbers will not come in any particular order. Following Q lineswill have Q queries. Be assured, none of the input numbers aregreater than 10000 and none of them are negative.

Input is terminated by a test casewhere N = 0 and Q = 0.

Output 

For each test case output the serial numberof the case.

For each of the queries, print one line ofoutput. The format of this line will depend upon whether or not the querynumber is written upon any of the marbles. The two different formats aredescribed below:

  • `x found at y', if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.
  • `x not found', if the marble with number x is not present.

Look at the output for sample input fordetails.

Sample Input 

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output 

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

代码:

#include<iostream>

#include<algorithm>

using namespacestd;

const int maxn =10000;

int a[maxn+10];

 

int main()

{

    int N,Q,kase = 1;

   while(~scanf("%d%d",&N,&Q) && N)

    {

        printf("CASE# %d:\n",kase++);

        for(int i = 0; i < N; i++)

        {

            scanf("%d",&a[i]);

        }

        sort(a,a+N);

        while(Q--)

        {

            int x;

            scanf("%d",&x);

            int p = lower_bound(a,a+N,x) - a;

            if(a[p] == x)

            {

                printf("%d found at%d\n",x, p+1);

            }

            else

            {

                printf("%d notfound\n",x);

            }

        }

    }

    return 0;

}

使用STL中的sort函数+lower_bound函数

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值