1594 - Ducci Sequence

A Ducci sequenceis a sequence of n-tuples of integers. Given an n-tupleof integers (a1a2,... an),the next n-tuple in the sequence is formed by taking the absolutedifferences of neighboring integers:

(a1a2, ... an)  (| a1 - a2|,| a2 - a3|, ... ,| an - a1|)

Ducci sequenceseither reach a tuple of zeros or fall into a periodic loop. For example, the4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8, 11, 2,7)  (3,9, 5, 1)  (6,4, 4, 2)  (2,0, 2, 4)  (2,2, 2, 2)  (0,0, 0, 0).

The 5-tuplesequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4, 2, 0, 2,0)  (2,2, 2, 2, 4)  (0,0, 0, 2, 2)  (0,0, 2, 0, 2)  (0,2, 2, 2, 2)  (2,0, 0, 0, 2) 

(2, 0, 0, 2,0)  (2,0, 2, 2, 2)  (2,2, 0, 0, 0)  (0,2, 0, 0, 2)  (2,2, 0, 2, 2) (0,2, 2, 0, 0) 

(2, 0, 2, 0,0)  (2,2, 2, 0, 2)  (0,0, 2, 2, 0)  (0,2, 0, 2, 0)  (2,2, 2, 2, 0) (0,0, 0, 2, 2)  ...

Given an n-tupleof integers, write a program to decide if the sequence is reaching to a zerostuple or a periodic loop.

Input 

Your program is toread the input from standard input. The input consists of T testcases. The number of test cases T is given in the first lineof the input. Each test case starts with a line containing an integer n (3n15), which represents thesize of a tuple in the Ducci sequences. In the following line, n integersare given which represents the n-tuple of integers. The range ofintegers are from 0 to 1,000. You may assume that the maximum number of stepsof a Ducci sequence reaching zeros tuple or making a loop does not exceed1,000.

Output 

Your program is towrite to standard output. Print exactly one line for each test case. Print`LOOP' if the Ducci sequence falls into a periodic loop, print `ZERO' if the Duccisequence reaches to a zeros tuple.

The followingshows sample input and output for four test cases.

Sample Input 

4

4

8 11 2 7

5

4 2 0 2 0

7

0 0 0 0 0 0 0

6

1 2 3 1 2 3

Sample Output 

ZERO

LOOP

ZERO

LOOP

代码:

#include<iostream>

#include<cmath>

using namespacestd;

 

int main()

{

    int test;

    cin>>test;

    int num[20];

   

    while(test--)

    {

        int n;

        cin>>n;

       

        for(int i=0;i<n;i++)

        {

            cin>>num[i];

        }

       

        bool flag=false;

        for(int i=1;i<=1010;i++)

        {

            int sum=0;

            int temp=num[0];

            for(int j=0;j<n-1;j++)

            {

                num[j]=abs(num[j+1]-num[j]);

                sum=sum+num[j];

            }

            num[n-1]=abs(temp-num[n-1]);

            sum=sum+num[n-1];

           

            if(sum==0)

            {

                cout<<"ZERO\n";

                flag=true;

                break;

            }

        }

       

        if(!flag)

        {

            cout<<"LOOP\n";

        }

       

    }

   

    return 0;

}

数据不大直接暴力

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值