Problem D: Longest Palindrome |
Time limit: 10 seconds |
A palindrome is a string that reads the same from the left as it does from the right. For example, I, GAG and MADAM are palindromes, but ADAM is not. Here, we consider also the empty string as a palindrome.
From any non-palindromic string, you can always take away some letters, and get a palindromic subsequence. For example, given the string ADAM, you remove the letter M and get a palindrome ADA.
Write a program to determine the length of the longest palindrome you can get from a string.
Input and Output
The first line of input contains an integer T (≤ 60). Each of the next T lines is a string, whose length is always less than 1000.
For ≥90% of the test cases, string length ≤ 255.
For each input string, your program should print the length of the longest palindrome you can get by removing zero or more characters from it.
Sample Input
2 ADAM MADAM
Sample Output
3 5
#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 1010
using namespace std;
int dp[Maxn][Maxn];
char s[Maxn];
int main()
{
int t;
scanf("%d%*c",&t);
while(t--){
gets(s);
int n=strlen(s);
for(int i=0;i<n;i++){
dp[i][i]=1;
if(s[i]==s[i+1]) dp[i][i+1]=2;
else dp[i][i+1]=1;
}
for(int l=2;l<n;l++)
for(int i=0,j=l;j<n;i++,j++)
if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1]+2;
else dp[i][j]=max(dp[i][j-1],dp[i+1][j]);
printf("%d\n",dp[0][n-1]);
}
return 0;
}