uva 11151 - Longest Palindrome

Problem D: Longest Palindrome

Time limit: 10 seconds


palindrome is a string that reads the same from the left as it does from the right. For example, I, GAG and MADAM are palindromes, but ADAM is not. Here, we consider also the empty string as a palindrome.

From any non-palindromic string, you can always take away some letters, and get a palindromic subsequence. For example, given the string ADAM, you remove the letter M and get a palindrome ADA.

Write a program to determine the length of the longest palindrome you can get from a string.

Input and Output

The first line of input contains an integer T (≤ 60). Each of the next T lines is a string, whose length is always less than 1000.

For ≥90% of the test cases, string length ≤ 255.

For each input string, your program should print the length of the longest palindrome you can get by removing zero or more characters from it.

Sample Input

2
ADAM
MADAM

Sample Output

3
5

又是一道回文串,这题更简单了。直接看代码吧。

代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 1010
using namespace std;

int dp[Maxn][Maxn];
char s[Maxn];
int main()
{
    int t;
    scanf("%d%*c",&t);
    while(t--){
        gets(s);
        int n=strlen(s);
        for(int i=0;i<n;i++){
            dp[i][i]=1;
            if(s[i]==s[i+1]) dp[i][i+1]=2;
            else dp[i][i+1]=1;
        }
        for(int l=2;l<n;l++)
            for(int i=0,j=l;j<n;i++,j++)
                if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1]+2;
                else dp[i][j]=max(dp[i][j-1],dp[i+1][j]);
        printf("%d\n",dp[0][n-1]);
    }
	return 0;
}

最长回文子串(Longest Palindrome Substring)是一个经典的字符串处理问题。给定一个字符串,要求找到其中最长的回文子串。回文串是指正读和反读都一样的字符串,例如"madam"和"racecar"。 解决这个问题的方法有很多,其中最常用的是中心扩展法和动态规划法。 ### 方法一:中心扩展法 中心扩展法的基本思想是遍历字符串的每一个字符,以该字符为中心,向两边扩展,找到最长的回文子串。需要注意的是,回文串的长度可能是奇数也可能是偶数,因此需要分别处理。 ```python def longest_palindrome(s): if not s: return "" start, end = 0, 0 for i in range(len(s)): len1 = expand_around_center(s, i, i) len2 = expand_around_center(s, i, i + 1) max_len = max(len1, len2) if max_len > end - start: start = i - (max_len - 1) // 2 end = i + max_len // 2 return s[start:end + 1] def expand_around_center(s, left, right): while left >= 0 and right < len(s) and s[left] == s[right]: left -= 1 right += 1 return right - left - 1 # 示例 s = "babad" print(longest_palindrome(s)) # 输出 "bab" 或 "aba" ``` ### 方法二:动态规划法 动态规划法的基本思想是将字符串的所有子串的子问题结果存储在一个二维数组中,然后通过已知的子问题结果推导出更大问题的结果。 ```python def longest_palindrome_dp(s): if not s: return "" n = len(s) dp = [[False] * n for _ in range(n)] start, max_len = 0, 1 for i in range(n): dp[i][i] = True for i in range(n - 1): if s[i] == s[i + 1]: dp[i][i + 1] = True start = i max_len = 2 for l in range(3, n + 1): for i in range(n - l + 1): j = i + l - 1 if s[i] == s[j] and dp[i + 1][j - 1]: dp[i][j] = True if l > max_len: start = i max_len = l return s[start:start + max_len] # 示例 s = "babad" print(longest_palindrome_dp(s)) # 输出 "bab" 或 "aba" ``` 这两种方法各有优缺点,中心扩展法实现简单,时间复杂度为O(n^2),而动态规划法虽然时间复杂度相同,但空间复杂度较高。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值