With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W
for win, T
for tie, and L
for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W
for the 3rd game, T
for the 2nd game, and T
for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W
, T
and L
.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
这题刚开始理解错了他的题意,以为是9个数中取最大的3个数。后面再细细阅读了一下,他的题意是选择每行最大的一个数,然后再做运算。
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
struct node
{
double a;int b;
}game[10000];
int number[5];
bool cmp(node a,node b)
{
return a.a<b.a;
}
int main()
{
double sum=0;
for(int i=0;i<9;i++)
{
cin>>game[i].a;
game[i].b=i;
}
sort(game,game+3,cmp);
sort(game+3,game+6,cmp);
sort(game+6,game+9,cmp);
sum=(game[2].a*game[5].a*game[8].a*0.65-1)*2;
number[0]=game[2].b;
number[1]=game[5].b;
number[2]=game[8].b;
sort(number,number+3);
for(int i=0;i<3;i++)
{
if(number[i]==0||number[i]==3||number[i]==6)
cout<<"W ";
else if(number[i]==1||number[i]==4||number[i]==7)
cout<<"T ";
else if(number[i]==2||number[i]==5||number[i]==8)
cout<<"L ";
}
printf("%.2lf",sum);
return 0;
}