#1117. Eddington Number【枚举 + 排序】

原题链接

Problem Description:

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E E E – that is, the maximum integer E E E such that it is for E E E days that one rides more than E E E miles. Eddington’s own E E E was 87.

Now given everyday’s distances that one rides for N N N days, you are supposed to find the corresponding E E E ( ≤ N \leq N N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N ( ≤ 1 0 5 \leq 10^5 105), the days of continuous riding. Then N N N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N N N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

Problem Analysis:

先将所有骑车里程数从小到大排序,然后从数组末尾往前枚举,由于一共只有 N N N 个里程数,因此 E E E 必满足 E ≤ N E\leq N EN,因此可以从大到小枚举 E E E,然后往前数 E E E 个数,看倒数第 n − E n - E nE 个数是否大于 E E E,如果是,则输出,并且这个数就是所要求的最大的 E E E

Code

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 1e5 + 10;

int n;
int a[N];

int main()
{
    cin >> n;
    for (int i = 0; i < n; i ++ ) scanf("%d", &a[i]);
    
    sort(a, a + n);
    for (int i = n; i; i -- )
        if (a[n - i] > i)
        {
            printf("%d", i);
            return 0;
        }
    puts("0");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值