PAT 1117 Eddington Number

1117 Eddington Number

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

思路: 一开始想的是用数组a数组b两个数组分别存储从小到大排序的数组和从大到小排序的数组,然后遍历从小到大的数组,看值(也就是距离在数组b中是否满足条件,这样会找不到最大的E 例子:a 2 3 6 6 7  8 8 9 10  b 10 9 8 8 7 6 6 3 2 这样查找6的时候就会不满足循环条件最后退出循环,e的答案是3)

代码:

#include <iostream>
#include <algorithm>
using namespace std;

bool cmp(int a,int b){return a>=b;}
int main(){
    int n,e=0;
    scanf("%d",&n);
    int a[n],b[n];
    for(int i=0;i<n;i++){
        scanf("%d",&a[i]);
        b[i]=a[i];
    }
    sort(a,a+n);//从小到大排序
    sort(b,b+n,cmp);//从大大小排序
    for(int i=0;i<n;i++){
        if(b[a[i]-1]>a[i] && a[i]<n-1)
            e=a[i];
        else break;
    }
    printf("%d\n",e);
    return 0;
}

正确的方法:

#include <iostream>
#include <algorithm>
using namespace std;

bool cmp(int a,int b){
    return a>b;
}
int a[10000010];
int main(){
    int n,e=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)    scanf("%d",&a[i]);
    sort(a,a+n,cmp);
    while(e<n && a[e]>e+1)  e++;//判断前e个数是否大于e英里,这样才不会遗漏
    printf("%d\n",e);
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值