数据结构基础+STL--sequence

Description

Given msequences, each contains n non-negative integer. Now we may select one numberfrom each sequence to form a sequence with m integers. It's clear that we mayget n ^ m this kind of sequences. Then we can calculate the sum of numbers in eachsequence, and get n ^ m values. What we need is the smallest n sums. Could youhelp us?

Input

The first lineis an integer T, which shows the number of test cases, and then T test casesfollow. The first line of each case contains two integers m, n (0 < m <=100, 0 < n <= 2000). The following m lines indicate the m sequencerespectively. No integer in the sequence is greater than 10000.

Output

For each testcase, print a line with the smallest n sums in increasing order, which isseparated by a space.

Sample Input

1

2 3

1 2 3

2 2 3

Sample Output

3 3 4

 

#include <cstdio>

#include <string>

#include <queue>

#include <iostream>

using namespace std;

int main()

{

   int t;

   int n,m;

   int num1[2010];

   int num2[2010];

   priority_queue<int,deque<int>,less<int> > big;

   scanf("%d",&t);

   while(t--)

    {

       scanf("%d%d",&m,&n);

       for(int i=0;i<n;i++)

       scanf("%d",&num1[i]);

       sort(num1,num1+n);

       for(int i=1;i<m;i++)

       {

           for(int j=0;j<n;j++)

           {

               scanf("%d",&num2[j]);

                big.push(num1[0]+num2[j]);

           }

           sort(num2,num2+n);

           for(int k=1;k<n;k++)

           for(int l=0;l<n;l++)

           {

               if(num1[k]+num2[l]>big.top())

                    break;

                    big.pop();

                    big.push(num1[k]+num2[l]);

           }

           for(int k=0;k<n;k++)

           {

                num1[n-k-1]=big.top();

                big.pop();

           }

       }

       printf("%d",num1[0]);

       for(int i=1;i<n;i++)

       printf(" %d",num1[i]);

cout<<endl;

          }

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值