搜索算法1之1002

1 题目编号:1002

2 题目内容:

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 

Author
Redow
 

3 解题思路形成过程:与problem 1002相似 ,求函数最小解 ,可以对其求导,在一般情况下,当F'(t) =0时,在x=t处有最小值,代入求解,然后利用二分法进行查找即可

4 代码:

#include<iostream>
#include<cmath>
using namespace std;
double g(double x)
{
return 42.0*pow(x, 6.0) + 48.0*pow(x, 5.0) + 21.0*pow(x, 2.0) + 10.0*x;
}
double f(double x, double y)
{
return 6.0*pow(x, 7.0) + 8.0*pow(x, 6.0) + 7.0*pow(x, 3.0) + 5.0*pow(x, 2.0) - x*y;
}
int main(){
int t;
double y, l, h, mid;
cin>>t;
while (t--){
cin>>y;
if (g(100.0) - y <= 0){
cout<< f(100.0, y);
}
else
{
l = 0.0;
h = 100.0;
while (h - l>1e-8){
mid = (h + l) / 2.0;
if (g(mid) - y<0)
l = mid;
else
h = mid;
}
cout<<fixed<<f(mid, y)<<endl;
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值