动态规划3之1002

1 题目编号:1002

2 题目内容:

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

3 题意:求出两个串的公共子序列的长度。

4 解题思路形成过程:p[i][j]表示s1长度为i的前缀和s2长度为j的前缀的最长公共子序列的长度。考虑s1的第i+1个字符位置要么匹配。要么不匹配。匹配的话只能和前j个位置匹配。如果s1[i+1]==s2[j]的话那么dp[i+1][j]=dp[i][j-1]+1很显然成立。如果s1[i+1]!=s2[j]的话i+1只能和前s2 的前j-1个位置匹配。dp[i+1][j]=dp[i+1][j-1]不匹配前s1的i+1个位置的话。dp[i+1][j]=dp[i][j]。那么dp[i+1][j]=max(dp[i][j],dp[i+1][j-1])这样就把s1的第i+1个位置确定了。

5 代码:#include <iostream>  
#include<stdio.h>  
#include<string.h>  
using namespace std;  
const int maxn=1010;  
int dp[maxn][maxn];  
char s1[maxn],s2[maxn];  
int main()  
{  
    int i,j,len1,len2;  
  
    while(~scanf("%s%s",s1+1,s2+1))  
    {  
        len1=strlen(s1+1);  
        len2=strlen(s2+1);  
        memset(dp[0],0,sizeof dp[0]);  
        for(i=1;i<=len1;i++)  
        {  
            for(j=1;j<=len2;j++)  
            {  
                if(s1[i]==s2[j])  
                    dp[i][j]=dp[i-1][j-1]+1;  
                else  
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);  
            }  
        }  
        printf("%d\n",dp[len1][len2]);  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值