湖大oj10049

IP Address
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 2578, Accepted users: 2420
Problem 10049 : No special judgement
Problem description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:

27 26 25 24 23 22 21 20 128 64 32 16 8 4 2 1 
 
Input
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.
 
Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation. 
 
Sample Input
4
00000000000000000000000000000000 
00000011100000001111111111111111 
11001011100001001110010110000000 
01010000000100000000000000000001 
Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
Problem Source
MCA 2004

#include<iostream>
#include<string>
#include<math.h> 
using namespace std;
int zhuanhua(string n, int sum) {
	//定义字符串n
	//定义转化为十进制的数字为sum
	//	cout<<"请输入二进制数字:";

	for (int i = 0; i < n.size(); i++)
	{
		//边界条件判断 递归思想(我想应该是递归思想吧,哈哈),也可写个else if判断条件为这个,如果不是输出非法输入再break掉也可以。
		if (n[i] > '1')
		{
			cout << "非法输入";
			return 0;//直接退出
		}
		//判断当前字符串n[i]是否为1,因为不是1就是0,为0的话,0的2次方还是等于0,不需要加法运算。
		if (n[i] == '1')
		{
			int j = pow(2, n.size() - i - 1);//这里考虑好二进制转化成十进制公示里面i和次方的关系
			sum += j;
		}
	}
	return sum;

}
int main() {
	int n;
	cin >> n;
	//按照题意应该建立结构体数组  关于string类型的 数组
	string* newarr = new string[n];//建立结构体string的数组 
	for (int i = 0; i < n; i++) {
		cin >> newarr[i];

	}
	//在进行没把为的怕暖
	for (int j = 0; j < n; j++) {
		string temp;
		for (int i = 0; i < newarr[j].size(); i += 8) {
			temp = newarr[j].substr(i, 8);//原来是题意的理解错误!  后面的一个数字不是编辑室位置 而死标表示后面多少个数字
			cout << zhuanhua(temp, 0);
			if (i + 8 < newarr[j].size()) {
				cout << ".";
			}
			
//难道【判断i+=8是无效的?
//事实证明了是没有用的
 
 
		}
		cout << endl;
	}



	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值