PAT Advanced 1155 Heap Paths (30 )

题目描述

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heapif it is a max heap, or Min Heapfor a min heap, or Not Heapif it is not a heap at all.

Sample Input:

8
98 72 86 60 65 12 23 50

Sample Output:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

解题思路

这大概是PAT 甲级里面,最简单的30分题之一了。。无脑dfs就好了

Code

  • AC代码
#include<bits/stdc++.h>
using namespace std;
int N, isHeap, isMax;
vector<int> v;

void dfs(int cur, vector<int> path) {
	if(cur > N) return;
	path.push_back(v[cur]);
	int cl = cur*2, cr = cur*2+1;
	if(cr <= N) {
		dfs(cr, path);
	}
	if(cl <= N) {
		dfs(cl, path);
	} else {
		for(int i = 0; i<path.size(); i++) {
			cout << path[i];
			i != path.size() -1 ? cout << ' ' : cout << '\n';
			if(i > 0 && isHeap) {
				if(isMax && path[i] > path[i-1]) {
					isHeap = false;
				} else if(!isMax && path[i] < path[i-1]){
					isHeap = false;
				}
			}
		}
	} 
	path.pop_back();
	
}
int main() {
	//freopen("in.txt", "r", stdin);
	cin >> N;
	v.resize(N+1);
	for(int i = 1; i<=N; i++) {
		cin >> v[i];
	}
	isHeap = true;
	isMax = v[1] >= v[2];
	vector<int> temp;
	dfs(1, temp);
	if(!isHeap) {
		cout << "Not Heap\n";
	} else if(isMax) {
		cout << "Max Heap\n";
	} else {
		cout << "Min Heap\n"; 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值