C - Bellovin

Peter has a sequence  a1,a2,...,an a1,a2,...,an and he define a function on the sequence --  F(a1,a2,...,an)=(f1,f2,...,fn) F(a1,a2,...,an)=(f1,f2,...,fn), where  fi fi is the length of the longest increasing subsequence ending with  ai ai

Peter would like to find another sequence  b1,b2,...,bn b1,b2,...,bn in such a manner that  F(a1,a2,...,an) F(a1,a2,...,an) equals to  F(b1,b2,...,bn) F(b1,b2,...,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one. 

The sequence  a1,a2,...,an a1,a2,...,an is lexicographically smaller than sequence  b1,b2,...,bn b1,b2,...,bn, if there is such number  i i from  1 1 to  n n, that  ak=bk ak=bk for  1k<i 1≤k<i and  ai<bi ai<bi.
Input
There are multiple test cases. The first line of input contains an integer  T T, indicating the number of test cases. For each test case: 

The first contains an integer  n n  (1n100000) (1≤n≤100000) -- the length of the sequence. The second line contains  n n integers  a1,a2,...,an a1,a2,...,an  (1ai109) (1≤ai≤109).
Output
For each test case, output  n n integers  b1,b2,...,bn b1,b2,...,bn  (1bi109) (1≤bi≤109) denoting the lexicographically smallest sequence. 
Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5
Sample Output
1
1 1 1 1 1
1 2 3

题意:寻找和一个序列增减性相同的另一个序列,若有多个,按字典序排序最小的输出。。。

思路:输出以第i个数为终点的最长子序列的长度即可;注意,不能用LIS中复杂度为O(n^2)的算法,否则超时。。。

下面附上我的代码:

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
const int M=100010;
int dp[M],a[M],b[M];
int main()
{
	int n,p;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&p,&a[0]);
		int ans=1;
		dp[1]=a[0];
		b[0]=ans;
		for(int i=1;i<p;i++)
		{
			scanf("%d",&a[i]);
			if(a[i]>dp[ans])
			{
				ans++;
				dp[ans]=a[i];
				b[i]=ans;
			}
			else
			{
				b[i]=lower_bound(dp,dp+ans,a[i])-dp;
				dp[b[i]]=a[i];
			}
		}
		for(int i=0;i<p;i++)
			printf("%d%c",b[i],i==p-1?'\n':' ');
	}
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值