POJ 2406 KMP 解题报告

Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

【解题报告】
题目大意,求字符串的最大循环次数 (完整的循环 )。
方法一
可HashHash Hash,枚举循环节长度 即可。复杂O( lenlen /1+len/2+3+… /1+len/2+3+… /1+len/2+3+… lenlen /lenlen ), 调和级数,近似于 O( lenlen *log( lenlen )) 。
方法二
利用性质,如果 lenlen -fail[fail[ fail[fail[lenlen ]整除 lenlen ,答案即 lenlen -fail[fail[ fail[fail[lenlen ],否则循环次数 为1 ( 即无循环节 )。预处理 failfail 数组 O(n) O(n) ,单次 O(1) O(1)O(1)。
首先, lenlen -fail[fail[ fail[lenlen ]是不要求边界的循环节完整最短长度 (以下所 述的循环节均不要求完整 ),这个很显然。那么一比较暴力的做法就是 不停跳 failfail ,找到第一个满足整除的 lenlen -fail’ fail’ fail’ 。但实际上不必继续跳 failfail 。
因为 根据裴蜀定理,一个串有长度a 的循环节,且有长度为 b 的循环 节,那么一定有 gcdgcdgcd(a,b )的循环节。 (需要长为 a和b的循环节 至少两)
于是 lenlen -fail[fail[ fail[lenlenlen]是该串所有可能的完整节数不少于 2的 循环节长度gcdgcdgcd, 既然 lenlen -fail[fail[ fail[lenlen ]不整除 lenlen ,那么它的倍数也不会整除 lenlen ,故没有必要继 续跳 failfail ,

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 1000010 

char p[N];  
int m,nxt[N];

void getnext()  
{  
    int i=0,j=nxt[0]=-1;  
    while(i<m)  
    {  
        if(j==-1||p[i]==p[j])  
        {  
            ++i;++j;  
            nxt[i]=p[i]!=p[j]?j:nxt[j];  
        }  
        else j=nxt[j];  
    }  
}    
int main()  
{  
   while(scanf("%s",p)!=EOF)  
    {  
        if(p[0]=='.') break;  
        m=strlen(p);  
        getnext();  
        int ans=1;  
        if(!(m%(m-nxt[m]))) ans=m/(m-nxt[m]);  
        printf("%d\n",ans);  
    }  
    return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值