Oil Deposits(深度或广度搜索)

这篇博客探讨了在解决HDOJ 1241问题中,如何利用深度优先搜索(DFS)和广度优先搜索(BFS)策略寻找油藏。通过实例解析,阐述了这两种算法在解决实际问题时的思路和优劣,对于ACM竞赛和算法学习者具有参考价值。
摘要由CSDN通过智能技术生成

HDOJ 1241:


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
 

Recommend
Eddy
 

深搜学习来自 gzhu_101majia

#include<iostream>
using namespace std;
int n,m;
char map[110][110];
void dfs(int i,int j)
{
	if(map[i][j]!='@'||i<0||i>=m||j<0||j>=n)//如果越界或不为'@',则退出;否则从八个方位搜索,找到更改为'*';
		return ;
	map[i][j]='*';
	dfs(i+1,j);
	dfs(i-1,j);
	dfs(i,j+1);
	dfs(i,j-1);
	dfs(i+1,j+1);
	dfs(i+1,j-1);
	dfs(i-1,j+1);
	dfs(i-1,j-1);
}
int main()
{
	//freopen("a.txt","r",stdin);
	while(cin>>m>>n&&n&&m)
	{
		int sum=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				cin>>map[i][j];
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				if(map[i][j]=='@')
				{
					dfs(i,j);
					sum++;
				}
		cout<<sum<<endl;
	}
}

广搜,纯粹是为了练习算法,其实该题没深搜快,且代码也较多。思想和深搜一样,能搜到说明为一个储量,标记为'*'。

#include<iostream>
#include<queue>
using namespace std;
struct node{
	int x,y;
};
char s[110][110];
int sum,m,n;
int dir[8][2]={1,0,0,1,-1,0,0,-1,1,1,-1,1,1,-1,-1,-1};
bool check(int x,int y)//判断越界和是否搜到'@';
{
	if(x>=0&&x<m&&y>=0&&y<n&&s[x][y]=='@')
		return true;
	return false;
}
void bfs()
{
	queue<node>Q;
	for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		{
			node start;
			if(s[i][j]=='@')//发现新储蓄块;
			{
				s[i][j]='*';
				sum++;
				start.x=i;
				start.y=j;
				Q.push(start);
				while(!Q.empty())
				{
					node temp=Q.front();
					Q.pop();
					for(int i=0;i<8;i++)//朝8个方向搜;
					{
						node t;
						t.x=temp.x+dir[i][0];
						t.y=temp.y+dir[i][1];
						if(check(t.x,t.y))//搜到记录并标记,弹进队列中;
						{
							s[t.x][t.y]='*';
							Q.push(t);
						}
					}
				}
			}
		}
}
int main()
{
	//freopen("a.txt","r",stdin);
	while(cin>>m>>n&&m&&n)
	{
		sum=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				cin>>s[i][j];
		bfs();
		cout<<sum<<endl;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值