Expired?(石油大学,2018年暑假集训)

问题 B: Expired?

时间限制: 1 Sec  内存限制: 128 MB
提交: 165  解决: 73
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Takahashi has a strong stomach. He never gets a stomachache from eating something whose "best-by" date is at most X days earlier. He gets a stomachache if the "best-by" date of the food is X+1 or more days earlier, though.
Other than that, he finds the food delicious if he eats it not later than the "best-by" date. Otherwise, he does not find it delicious.
Takahashi bought some food A days before the "best-by" date, and ate it B days after he bought it.
Write a program that outputs delicious if he found it delicious, safe if he did not found it delicious but did not get a stomachache either, and dangerous if he got a stomachache.

Constraints
1≤X,A,B≤109

 

输入

Input is given from Standard Input in the following format:
X A B

 

输出

Print delicious if Takahashi found the food delicious; print safe if he neither found it delicious nor got a stomachache; print dangerous if he got a stomachache.

 

样例输入

4 3 6

 

样例输出

safe

 

提示

He ate the food three days after the "best-by" date. It was not delicious or harmful for him.

 

解析:题目很简单,可能出错的地方我已经用红字标出了。

#include <iostream>

using namespace std;

int main()
{
    long long x, a, b;
    while(cin>>x>>a>>b){
        if(b <= a+1)
            cout<<"delicious"<<endl;
        else if(b <= a+x)
            cout << "safe" << endl;
        else
            cout << "dangerous"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值