1051. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

题目大意:

给定一个栈,他最多可以保留M个数字。按1, 2, 3, ..., N的顺序进栈并随机出栈。你的任务是判断一个给定的数字序列是否是正确的出栈顺序。例如,如果M是5N是7,我们可以从堆栈中的到1, 2, 3, 4, 5, 6, 7,但不是3, 2, 1, 7, 5, 6, 4。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,第一行包含3个数字(都不超过1000):M(堆栈的最大容量),N(进栈队列的长度),K(要检查的出栈序列的数量)。然后是K行,每行包含一个有N个数字组成的序列。直线上得所有数字都用空格隔开。
输出规范:
对于每个打印序列,如果他确实是堆栈的一个可能的出栈序列,打印“YES”,否则打印“NO”。

代码:

#include<stdio.h>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
    int i,j,n,m,k,t,l,flag;
    scanf("%d %d %d",&n,&m,&k);
    for(i=0;i<k;i++)
    {
        l=1;
        flag=0;
        stack<int> s;
        for(j=0;j<m;j++)
        {

            scanf("%d",&t);
            if(flag==0)
            {
                while(s.empty()||s.top()!=t)
                {
                    s.push(l);
                    if(s.size()>n)
                    {
                        flag=1;
                        break;
                    }
                    l++;
                }
                if(flag==0&&s.size()>=1&&s.top()==t)
                {
                    s.pop();
                }
            }
        }
        if(flag==0)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值