PAT甲级刷题记录——1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路

这题一开始想不到用什么好的方法来做,之前做过一个计算有几种出栈序列的题:【问题 E: 【递归入门】出栈序列统计】,因此,自然而然地想用递归的方式把所有出栈序列都计算出来,然后判断题目所给的序列是不是和这些出栈序列中的一种相等,如果是,那么输出“YES”,如果一种都不符合,那么输出“NO”。但是要是给的N太大(题目的N≤1000)的话,用递归算就会非常麻烦,很容易产生爆栈的情况。再思考一下,我们只需要判断题目给出的序列是不是出栈序列即可,那么就完全没有必要计算出所有的出栈序列再逐个比较了(显然是浪费时间的一种做法)。所以,我们就要从给出的序列入手,这里我参考了柳神的思路(这题的思路非常重要!!可以少走很多弯路):

首先定义一个m=1,代表着从1~N的入栈序列。然后,在while循环里不断压栈(直到m>N时结束while循环),压完之后判断:①如果当前栈中的元素个数已经大于容量M了,那么break,并且令flag为false(flag初值设为true),说明这种方案不可行;②如果当前栈非空且栈顶元素等于index指向序列的当前的元素,那么出栈,并且让index++,使其指向序列的下一个元素,并且,只要一直满足【栈非空且栈顶元素等于index指向序列的当前的元素】这个条件,那么就一直出栈。

最后,如果while(m<=N)循环结束之后:

  • flag还是false,那么显然这是因为超过容量break掉的情况,方案是不成立的,输出“NO”;
  • 如果flag是true,但是栈并不是空的,说明这种情况是只能完成序列的一部分(比如样例第二行的3 2 1 7 5 6 4,这种情况下会正常结束while循环,并且flag也是true,但并不是可行方案,因为出栈序列只能到3 2 1 7,下一个应该是6,而给出的序列中是5),所以方案也是不成立的,也要输出“NO”;
  • 如果flag是true,并且栈也是空的,那么说明这种方案是完全成立的,也就是说,完全能通过出栈的方式得到这整一个序列,输出“YES”。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<stack>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 1010;
int tmpSeq[maxn] = {0};
int M, N, K;
int main(){
    scanf("%d%d%d", &M, &N, &K);
    for(int i=0;i<K;i++){
        for(int j=1;j<=N;j++) scanf("%d", &tmpSeq[j]);
        stack<int> MyStack;
        int index = 1;//指向tmpSeq的pointer
        int m = 1;//1~N的待入栈序列
        bool flag = true;
        while(m<=N){
            MyStack.push(m);
            m++;
            if(MyStack.size()>M){
                flag = false;
                break;
            }
            else{
                while(MyStack.empty()==false&&MyStack.top()==tmpSeq[index]){
                    MyStack.pop();
                    index++;
                }
            }
        }
        if(MyStack.empty()==true&&flag==true) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值