02-线性结构4 Pop Sequence (25分)(简单堆栈实现)

02-线性结构4 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题意:将 1 ~ K个元素压入栈中,判断给定的N组序列是否可能是弹出的序列。

M: 堆栈的最大容量 K: 要检查的pop序列数  N:推序列的长度

解题思路:模拟堆栈的压入弹出操作,首先将栈制空,随后判断弹出的序列值是否与堆栈头相等,如果相等将头部弹出。如果不相等继续堆栈压入操作直到堆栈头与其相等,如果堆栈头大于序列值,那么值被压倒下面无法弹出。

#include<iostream>
#include<stack>
using namespace std;
int main()
{
    int M , K , N,A[1000];
    cin >> M >> K >> N;
    stack<int> S;
    while(N--)
    {
        int flag = 1;   // flag 为 1 代表无错误
        int num = 0;    // 代表需要压入的值
        int countt = 0; // 记录当前堆栈内元素数量
        while(!S.empty())  // 初始化堆栈
              S.pop();
        for(int i = 0 ; i < K ; i++)
        {
            cin >> A[i];
        }
        for(int i = 0 ; i < K ; i++)
        {

            if(S.empty())     // 如果当前堆栈为空 将1压入
            {
                S.push(++num);
                countt++;
            }
            if(S.top() == A[i])  // 如果堆栈头与序列值相等,弹出堆栈头
            {
                S.pop();
                countt--;
            }
            else if(S.top() < A[i])  // 如果堆栈头小于序列值
            {
                while(S.top() != A[i])  // 压入操作,直到堆栈头与序列值相等
                {
                    S.push(++num);
                    countt++;
                    if(countt > M)    // 判断压入数量是否超过规定堆栈大小
                    {
                        flag = 0;
                        break;
                    }
                }
                S.pop();            //压入完成后 将堆栈头弹出
                countt--;
            }
            else if (S.top() > A[i]) // 堆栈头大于序列值情况
            {
                flag = 0 ;
                break;
            }
        }
        if(flag == 0)
        {
            cout << "NO\n";
        }
        else
        {
            cout << "YES\n";
        }
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值