02-线性结构3. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. Youare supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and Nis 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

继续学习数据结构。

这个题目对我来说有点困难,我竟然不知道有stack这个库,还用vector来模拟,这样会比较烦,比较烦,下次就知道了,还是见识窄啊。

题目的解题思路是简单的,就是比较当前栈的top值,和当前的数值,不相等的话,就一直push进来,直到相等,或者是溢出MaxSize。

code如下:


#include <iostream>
#include <stack>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv) {
	int MaxSize=0,N=0,K=0;
	int a[1010];
	scanf("%d %d %d",&MaxSize,&N,&K);

//	for(i=0;i<N;i++) v.push_back(i);
	for(int i=0; i<K; i++)
	{
		int idx=1;
		bool flag=true;
		std::stack<int> s;
		for(int j=0; j<N; j++)
		{
			scanf("%d",&a[j]);
			if(flag)
			{
				while(s.empty() || s.top() != a[j])
				{
					s.push(idx);
					if(s.size()>MaxSize)
					{
						flag=false;
						break;
					}
					idx++;
				}
				if(flag && s.size()>=1 && s.top()==a[j]) s.pop();
			}

		}
		if(!flag) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值