1127. ZigZagging on a Tree (30)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

题目大意:


代码:

#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
vector<int> v[50];
int l=0;
struct node
{
    int data;
    struct node *lchild,*rchild;
};
struct node *create(int n,int a[],int b[])
{
    if(n<=0)
    {
        return NULL;
    }
    struct node *root=(struct node *)malloc(sizeof(struct node));
    root->data=b[n-1];
    int *p;
    for(p=a;*p!=b[n-1];p++);
    int t=p-a;
    root->lchild=create(t,a,b);
    root->rchild=create(n-t-1,p+1,b+t);
    return root;
}
void level(struct node *root)
{
    queue<struct node *> q;
    q.push(root);
    int lastnode=root->data;
    while(!q.empty())
    {
       struct node *tmp=q.front();
       q.pop();
       if(tmp!=NULL)
       {
           v[l].push_back(tmp->data);
           q.push(tmp->lchild);
           q.push(tmp->rchild);
           if(lastnode==tmp->data)
           {
               if(tmp->rchild!=NULL)
                lastnode=tmp->rchild->data;
               else if(tmp->lchild!=NULL)
                lastnode=tmp->lchild->data;
               l++;
           }
       }
    }

}
void preorder(struct node *root)
{
    if(root!=NULL)
    {
        printf("%d ",root->data);
        preorder(root->lchild);
        preorder(root->rchild);
    }
}
int main()
{
    int i,j,n,m,k,t;
    int a[50],b[50];
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=0;i<n;i++)
    {
        scanf("%d",&b[i]);
    }
    struct node *root=create(n,a,b);
    level(root);
    int flag=0;
    for(i=0;i<=l;i++)
    {
        if(i%2==0)
        {
            for(j=v[i].size()-1;j>=0;j--)
            {
                if(flag==0)
                {
                    printf("%d",v[i][j]);
                    flag=1;
                }
                else
                {
                    printf(" %d",v[i][j]);
                }
            }
        }
        else
        {
            for(j=0;j<v[i].size();j++)
            {
                if(flag==0)
                {
                  printf("%d",v[i][j]);
                }
                else
                {
                    printf(" %d",v[i][j]);
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值