Machine

There is a machine with m(2≤m≤30)m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 
For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed n(1≤n<263)n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15)T(1≤T≤15) indicating the number of test cases. For each test case: 

The only line contains two integers m(2≤m≤30)m(2≤m≤30) and n(1≤n<263)n(1≤n<263).

Output

For each test case, output the colour of m bulbs from left to right. 
R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

题解:相当于把一个数转换为三进制,超出m位的舍去即可;

其中 0=R,1=G, 2=B;

注意n的值比较大,需要用 long long 格式

代码:

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int t,a[30],m,i;
    long long n;
    scanf("%d",&t);
    while(t--){
        scanf("%d%lld",&m,&n);
        for(i=0;i<30;i++) a[i]=0;//重置数组
        i=m-1;
        while(n && i>=0){
            a[i]=n%3;
            n=n/3;
            i--;
        }
        for(i=0;i<m;i++)
            switch(a[i]){
                case 0: printf("R"); break;
                case 1: printf("G"); break;
                case 2: printf("B"); break;
            }
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值