N!
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 89726 Accepted Submission(s): 26523
Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
Input
One N in one line, process to the end of file.
Output
For each N, output N! in one line.
Sample Input
1 2 3
Sample Output
1 2 6
#include<stdio.h>
int main()
{
int i,j,m,n;
while(scanf("%d",&n)!=EOF)
{
if(n<0)continue;
int a[10000]={1};
int m=0;
for(i=1;i<=n;i++)
{
for(j=0;j<=m;j++)
{
a[j]=a[j]*i;
if(j>0&&a[j-1]>10000)
{
a[j]=a[j]+a[j-1]/10000;
a[j-1]=a[j-1]%10000;
}
if(a[m]>10000)
m++;
}
}
printf("%d",a[m]);
for(i=m-1;i>=0;i--)
{
printf("%04d",a[i]);
}
printf("\n");
}return 0;
}