1078 Hashing (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.
Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意:创建一个质数大小的哈希表,然后进行插入操作,哈希函数为k=k%size
如果发生冲突,利用平方探测法进行解决,只进行正向探测
注意点:利用素数判断函数进行表长的判断,输出格式的最后不可以有空格,当超出步长是应该输出‘ - ’;

AC代码

#include<stdio.h>
#include<math.h>
bool hashtable[100100]={0};
bool is_prime(int n){
	if(n<=1)return false;
	int k=(int)sqrt(1.0*n);
	for(int i=2;i<=k;i++){
		if(n%i==0){
			return false;
		}
	}
	return true;
}
int main(){
	int size,num;
	scanf("%d%d",&size,&num);
	while(is_prime(size)!=true){
		size++;
	}
	for(int i=0;i<num;i++){
		int temp;
		scanf("%d",&temp);
		if(hashtable[temp%size]==false){
			hashtable[temp%size]=true;
			if(i==0)printf("%d",temp%size);
			else printf(" %d",temp%size);
		}else{
			int step;
			for(step=1;step<size;step++){
                int k=(temp+step*step)%size;
				if(hashtable[k]==false){
					hashtable[k]=true;
					if(i==0)printf("%d",k);
					else printf(" %d",k);
                    break;
				}
			}
            if(step==size){
                if(i==1)printf("-");
                else printf(" -");
            }
		}	
	}
	printf("\n");
	return 0;	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值