1056 Mice and Rice (25分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.
Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

题意:有np只老鼠,依次输入他们的体重,紧接着给出排序编号,按照排序编号给出的先后进行划分,最后从0输出;
思路:因为涉及到了晋级问题不妨使用对列,通过出队与入队来实现晋级的模拟。例如三人中晋级一人,先把三人全部出队,之后再把晋级的人进队,进行下一轮,直到最终获胜者产生。

AC

#include<stdio.h>
#include<queue>
using namespace std;
struct mouse{//老鼠结构体
	int weight;
	int rank;
}mouse[1010];
int main(){
	int np,ng,k;
	scanf("%d%d",&np,&ng);
	for(int i=0;i<np;i++){
		scanf("%d",&mouse[i].weight);//依次输入体重
	}
	queue<int>q;
	for(int i=0;i<np;i++){
		int temp;
		scanf("%d",&temp);
		q.push(temp);//编号输入
	}
	int n=np;
	while(q.size()!=1){//最终冠军产生条件
		int group;
		if(np%ng==0){//划分每一轮有几组
			group=np/ng;
		}else{
			group=np/ng+1;
		}
		for(int i=0;i<group;i++){//每组进行轮数
			k=q.front();
			for(int j=0;j<ng;j++){//每一划分进行判断
				if(i*ng+j>=np)break;//达到边界,该轮老鼠全部完成排列
				if(mouse[q.front()].weight>mouse[k].weight){
					k=q.front();
				}
				mouse[q.front()].rank=group+1;//有group老鼠晋级,所以排名是group+1
				q.pop();//淘汰
			}
			q.push(k);//晋级
		}
		np=group;//下轮老鼠数
	}
	if(q.size()==1){//因为循环结束时,mouse[q.front].rank=2所以要手动改1
		mouse[q.front()].rank=1;
	}
	for(int i=0;i<n;i++){
		printf("%d",mouse[i].rank);
		if(i<n-1)printf(" ");//格式输出
	}
	printf("\n");
	return 0;
	
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值