1103 Integer Factorization (30分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.
Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.
Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P

where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.
Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

题意:给定一个正整数N,给出K个数字,使得这K个数字的p次方和等于N(K<=N);
思路:先创建一个计算x^p的函数,再创建一个vector数组用以存储x ^p;每一个x ^p都有选用与不选用两种情况,因此我们可以使用DFS来解决;temp为临时结果,ans为最终结果。首先确定参数:1需要用一个数字表示第几个数字:index 2需要一个数字用以判断是否达到K:nowk 3需要判断和是否为N:sum 4 字典序判断:facsum。 接着判断递归条件:当nowk=K并且sum=N时返回,此时如果facsum>maxsum则更新maxsum与ans。如果nowk>k或者sum>N也返回。接着进行选择操作,细节看代码。

AC

#include<stdio.h>
#include<vector>
using namespace std;
int n,k,p;
vector<int>fac,temp,ans;
int facmax=-1;
int cal(int x){//计算n^p
	int a=1;
	for(int i=0;i<p;i++){
		a=a*x;
	}
	return a;
}
void init(){//初始化fac
	int temp=0,i=0;
	while(temp<=n){
		fac.push_back(temp);
		temp=cal(++i);
	}
}
void DFS(int index,int nowk,int sum,int facsum){
	if(nowk==k&&sum==n){//递归终止条件
		if(facsum>facmax){//更新数据,字典序判断
			facmax=facsum;
			ans=temp;
		}
		return;
	}
	if(nowk>k||sum>n)return;
	if(index>=1){//
		temp.push_back(index);//选择当前index
		DFS(index,nowk+1,sum+fac[index],facsum+index);
		temp.pop_back();
		DFS(index-1,nowk,sum,facsum);//不选择当前index,从大到小判断节省时间
	}
}
int main(){
	scanf("%d%d%d",&n,&k,&p);
	init();
	DFS(fac.size()-1,0,0,0);
	if(facmax==-1)printf("Impossible");
	else{
		printf("%d = %d^%d",n,ans[0],p);
		for(int i=1;i<ans.size();i++){
			printf(" + %d^%d",ans[i],p);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值