PTA~02-线性结构3 Reversing Linked List~2020年12月

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​0000) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

答案

  • 注意输出之后的节点next域要修改。
#include<stdio.h>
#include<stdlib.h> 
typedef struct node{
	int address;
	int num;
	int next;
	struct node *link;
}node;
int start,n,k;
void read(node*);
void sort(node*,node*);
void reverse(node*,node*);
void output(node*);
void changeadd(node*);
int main(){
	scanf("%d%d%d",&start,&n,&k);
	node *a=NULL,*b=NULL;
	a=(node*)malloc(n*sizeof(node));
	a->link=NULL;
	b=(node*)malloc(n*sizeof(node));
	b->link=NULL;
	read(a);//input function
//	output(a); 
	sort(a,b);//sort a[] into b[]
//	printf("\n");output(b);printf("\n");
	reverse(a,b);//reverse b[] into a[]
	changeadd(a);
	output(a);//output function 

	return 0;
}

void read(node* a){
	int i=0;
	node*q=a,* r=NULL;
	while(i<n){
		r=(node*)malloc(sizeof(node));
		r->link=NULL;
		scanf("%d%d%d",&r->address,&r->num,&r->next);
		q->link=r;
		q=q->link;
		i++;
	}
}

void output(node *a){
	node*p=a->link;
	while(p){
		if(p->next==-1){
			printf("%05d %d -1\n",p->address,p->num);
		}
		else printf("%05d %d %05d\n",p->address,p->num,p->next);
		p=p->link;
	}
}
void sort(node*a,node *b){
	node*p=b;
	node *q=a,*r=a->link;
	int add=start;
	while(r){
		while(r){
			if(add==r->address)break;
			r=r->link;
			q=q->link;
		}
		if(r){
			p->link=r;
			p=p->link;
			q->link=r->link;
			r->link=NULL;
			add=r->next;
			q=a;r=a->link;
		}
	}
	if(a->link){
		q=a->link;r=q->link;
		a->link=NULL;
		while(r){
			free(q);
			q=r;
			r=r->link;
		}
		free(q);
	}
}
void reverse(node*a,node*b){
	node *p=a,*q=b->link;
	int i=0,j=0;
	while(q){
		while(q){
			i++;
			if(i==k){
				break;
			}
			q=q->link;
		}
		if(i<k){
			q=b->link;
			while(p->link)p=p->link;
			p->link=q;
			b->link=NULL;
			return;	
		}
		else {
			q=b->link;
			while(j<k){
				b->link=q->link;
				q->link=p->link;
				p->link=q;
				j++;
				q=b->link;
			}
			j=0;
			while(p->link)p=p->link;
		}
		i=0;	
	}	 
}	
void changeadd(node*a){
	node*p=a->link;
	while(p->link){
		p->next=p->link->address;
		p=p->link;
	}
	p->next=-1;
}		








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值