POJ - 1426 Find The Multiple 搜索+贪心

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100

111111111111111111

题意:

给定一个不超过200的正整数n,编写一个程序,求一个满足只包含0和1的十进制数(不超100位)能整除n,输入0时程序结束

解题思路:

题意翻译明白后,应该想到用搜索,用深搜。从1开始,判断能否整除n,可以的话输出,深搜结束,不可以就继续搜,只是每次搜都有两种情况,要么本身乘以十,要么本身乘以十再加一,这样就可以做到把包含0和1组合的十进制数遍历一遍。


注意:

long long型足以存下满足要求的数,应该是long long型范围内必定存在一个能整除1-200的只包含0和1的十进制数吧,另外特别注意不需要求满足题意的最小数,只要满足要求即可输出。


AC代码:

#include<stdio.h>

long long int sum;          //搜索函数和主函数都需要用
int n, flag;                //所以定义为全局变量

void dfs( long long x, int step )
{
    if( flag || step > 18 ) //如果找到满足题意的或者
        return ;            //超出long long型 返回
    if( x%n == 0 && x )
    {
        flag = 1;           //flag找到就标记
        printf("%lld\n",x);
        return ;
    }
    dfs(x*10,step+1);
    dfs(x*10+1,step+1);
}

int main()
{
    while( scanf("%d",&n) && n )
    {
        flag = 0;
        dfs(1,0);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值