A Simple Problem with Integers 线段树区间查询+区间修改

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 100883 Accepted: 31450
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source



简单的套用线段树的模板,用区间修改和区间查询,另外一点要注意的是,数据输出时候要用%lld, 还有就是add数组要开成 long long 的


AC代码:


#include<cstdio>
#include<cstring>   
#include<algorithm>
#include<iostream>
#include<string>
#include<cmath>
#include<iomanip>
using namespace std;
typedef long long ll;
const int maxn = 100002;


int n;
ll sum[maxn << 2], add[maxn << 2], people[maxn];


void pushup(int rt) {
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}


void build(int l, int r, int rt) {
	if(l == r) {
		sum[rt] = people[l];
		return;
	}
	int m = (l + r) >> 1;
	build(l, m, rt << 1);
	build(m + 1, r, rt << 1 | 1);
	pushup(rt);
}

void pushdown(int rt, int lnum, int rnum) {
	if(add[rt]) {
		add[rt << 1] += add[rt];   //这个地方一定要用+=, 因为这是一个累加的过程
		add[rt << 1 | 1] += add[rt];
		sum[rt << 1]  += add[rt] * lnum;  //这个地方乘的是add[rt],因为这次修改的是因为他的父节点而改变的带点
		sum[rt << 1 | 1] += add[rt] * rnum;
		add[rt] = 0;
	}
}


void update(int L, int R, int C, int l, int r, int rt) {
	if(l >= L && r <= R) {
		sum[rt] += C * (r - l + 1);
		add[rt] += C; //同一个点可能被多次标记,所以用 +=,而不用= 
		return;
	}
	int m = (l + r) >> 1;
	pushdown(rt, m - l +1, r - m);
	if(L <= m)  update(L, R, C, l, m, rt << 1);
	if(R > m)  update(L, R, C, m+1, r, rt << 1 | 1);
	pushup(rt);
}


ll query(int L, int R, int l, int r, int rt) {
	if(l >= L && r <= R) {
		return sum[rt];
	}
	int m = (r + l) >> 1;
	ll ans = 0;
	pushdown(rt, m - l + 1, r - m);
	if(L <= m)  ans += query(L, R, l, m, rt << 1);
	if(R > m)  ans += query(L, R, m + 1, r, rt << 1 | 1);
	return ans;
}

int main()
{
	int q = 0;
	char que[2];
	scanf("%d %d",&n, &q);
	int i;
	for(i=1; i<=n; ++i)
		scanf("%lld",&people[i]);
	build(1, n, 1);
	int a, b, c;
	while(q--) {
		scanf("%s", que);
		if(que[0] == 'Q') {
			scanf("%d %d", &a, &b);
			printf("%lld\n",query(a, b, 1, n, 1));
		}
		else {
			scanf("%d %d %d", &a, &b, &c);
			update(a, b, c, 1, n, 1);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值