Smallest Difference(Poj2718)(枚举全排列next_Permutation)

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6664 Accepted: 1815

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

Source



首先先说下next-permutationSTL模版函数的用法,从字典序最小排列开始,不停调用”求下一个排列“的过程。
例如:求数组n个数的全排列。模版代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int n,p[10];
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	scanf("%d",&p[i]);
	sort(p,p+n);
	do{
		for(int i=0;i<n;i++) printf("%d ",p[i]);
		printf("\n");
	}while(next_permutation(p,p+n));
	return 0;
}


本题题意就是求给你一些数字,分成两组,求两组中组成数字的最小差值。显然如果n个数字分成两组,这两组数字
个数越接近,组成的数的差值就较小。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;

int main()
{
	int n,num,ans;
	char s[100];
	int a[11];
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		gets(s);
		num=0;
		ans=0x3f3f3f;
		for(int i=0;i<strlen(s);i++)
		{
			if(s[i]>='0'&&s[i]<='9')
			a[num++]=s[i]-'0';
		}
		sort(a,a+num);
		do{
			int num1=0,num2=0,k=1;
			if(!a[num/2-1]||!a[num-1]&&num>2) //当数字个数超过3个,要考虑最高位0的情况~ 
			     continue;
			for(int i=0;i<num/2;i++)
			{
				num1+=k*a[i];
				k*=10;
			}
			k=1;
			for(int i=num/2;i<num;i++)
			{
				num2+=k*a[i];
				k*=10;
			}
			ans=min(ans,abs(num1-num2));
		}while(next_permutation(a,a+num));
		printf("%d\n",ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值