HDOJ 4786 Fibonacci Tree(最小生成树--kruskul)

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3004    Accepted Submission(s): 964


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No 看下数据范围,果断kruskul,这道题的意思是,看一下是否建立一个连通图,然后 其白色边的数量等于一个fibonacci数,因为数据范围最大为100000,所以直接打 表fibonacci数,然后求得最大生成树白色边数量和最小生成树白色边数量,然后查看 是否有fibonacci数在这个范围中即可 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1000010
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
using namespace std;
int sum,ans;
int pri[MAXN];
int fibonacci[26]={0,1,2,3,5,8,13,21,34,55,89,144,233,377,610,987,1597,2584,4181,6765,10946,17711,28657,46368,75025};//打表
struct s
{
	int a;
	int b;
	int cost;
}dis[MAXN];
bool cmp(s A,s B)
{
	return A.cost<B.cost;
}
int find(int x)
{
	int r=x;
	while(r!=pri[r])
	r=pri[r];
	int i=x,j;
	while(i!=r)
	{
		j=pri[i];
		pri[i]=r;
		i=j;
	}
	return r;
}
void connect(int xx,int yy,int num)
{
	int nx=find(xx);
	int ny=find(yy);
	if(nx!=ny)
	{
		pri[nx]=ny;
		ans++;//记录节点数量
		if(num==1)//记录白色边数量
		sum++;
	}
}
int main()
{
	int i,j,m,s,n;
	int t,q,num,k,low,high;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		pri[i]=i;
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&dis[i].a,&dis[i].b,&dis[i].cost);
		}
		sort(dis,dis+m,cmp);
		ans=0;
		for(i=0;i<m;i++)//最小生成树白色边数量
		{
			connect(dis[i].a,dis[i].b,dis[i].cost);
		}
		if(ans!=n-1)  //如果不能建立连通图,那么不用执行后面的了,直接输出No
        {  
            printf("Case #%d: No\n",++cas);  
            continue;  
        }
		low=sum;
		sum=0;
		for(i=1;i<=n;i++)//初始化联通
		pri[i]=i;
		for(i=m-1;i>=0;i--)//最大生成树白色边数量
		{
			connect(dis[i].a,dis[i].b,dis[i].cost);
		}
		high=sum;
		int bz=0;
		for(i=1;i<=24;i++)
		{
			if(fibonacci[i]>=low&&fibonacci[i]<=high)
			bz=1;
		}
		if(bz)
		printf("Case #%d: Yes\n",++cas);
		else
		printf("Case #%d: No\n",++cas);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值