HDOJ 5363 Key Set (快速幂取模)

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1161    Accepted Submission(s): 664


Problem Description
soda has a set S with n integers {1,2,,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first line contains an integer n (1n109) , the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
0 1 3 7 一看就出来的规律,但是不知道对不对,写了一下,还真对了= = ans=2^(n-1)-1


ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 2555
#define mod 1000000007
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
long long fun(long long x,long long y)
{
	long long sum=1;
	while(x)
	{
		if(x%2)
		sum=sum*y%mod;
		x/=2;
		y=y*y%mod;
	}
	return sum;
}
int main()
{
	long long t,num;
	scanf("%lld",&t);
	while(t--)
	{
		scanf("%lld",&num);
		long long ans=fun(num-1,2);
		printf("%lld\n",ans-1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值