UVa 156 Ananagrams (用STL multimap&set处理字典中的重复元素)

156 - Ananagrams

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=98&page=show_problem&problem=92

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon

思路:先用建立一个multimap<排序的词,未排序的词>来处理输入,完毕后将只有一个值的键放入一个set中,最后遍历set输出即可。(详见代码)


完整代码:

/*0.015s*/

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set>
using namespace std;

char s[25], origin[25];
multimap<string, string> map1;
set<string> set1;
multimap<string, string>::iterator pm;
set<string>::iterator ps;

int main()
{
	int len, i;
	while (scanf("%s", s), s[0] != '#')
	{
		strcpy(origin, s);
		len = strlen(s);
		for (i = 0; i < len; ++i)
			if (isupper(s[i])) s[i] = tolower(s[i]);
		sort(s, s + len);
		map1.insert(make_pair(s, origin));
	}
	for (pm = map1.begin(); pm != map1.end(); ++pm)
		if (map1.count(pm->first) == 1)
			set1.insert(pm->second);
	for (ps = set1.begin(); ps != set1.end(); ++ps)
		puts((*ps).c_str());
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值