POJ 2405 KMP next数组的运用 ʕ •ᴥ•ʔ

Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:求一个字符串的循环节循环了几次

先跑一遍next数组 用数组总长度-nexxt[len] 就是她循环节的长度 然后如果 总长度%循环节!=0 的话 就输出1  举例:abcdab

 需要注意的是不可以定义next数组 因为next好像是变量和int差不多

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#define N 0x3f3f3f3f
#define ll long long
using namespace std;
string s;
int nexxt[1000010];
void getnext()
{
	int i=0,j=-1;
	nexxt[0]=-1;
	int len=s.size();
	while(i<len)
	{
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			nexxt[i]=j;
		}
		else
		j=nexxt[j];
	}
	
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>s)
	{
		if(s==".")
		break;
		getnext();
		int len=s.size();
		int a=len-nexxt[len];
		if(len%a==0)
		printf("%d\n",len/a);
		else
		printf("1\n");
		
	}
	return 0;	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值