POJ 2976 Dropping tests 二分

 

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

 

我们看到这道题可能第一个思路就是贪心 但是实际上贪心是不对的 因为你不能保证分子和除以分母和等于大的分数之和

那我们怎么切入呢? 我们这样想

我需要sigama(ai)/sigama(bi)<=x(x就是我的最大值)

那么我是不是sigama(ai)-x*xigama(bi)<=0;

于是就有如下的代码了 注意最后是printf("%.0f);

或者你也可以强制int转换(int)(l*100+0.000000001);

欣赏代码吧

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1024;
int n,m;
double x;
struct node {
   int w;
   int s;
   bool operator < (const node& other) const{
      return w-x*s>other.w-x*other.s;
   }
}arr[MAX_N];
int check(double p){
    double total_a = 0, total_b = 0;
    x = p;
    sort(arr+1,arr+1+n);
    for(int i = 1;i<=(n-m);++i){
        total_a+=arr[i].w;
        total_b+=arr[i].s;
    }
    return total_a/total_b > p;
}
int main(){
 while(~scanf("%d%d",&n,&m)&&(n||m)){
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].w);
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].s);
    double l = 0,r=1;
    while(abs(r-l)>1e-4){
        double mid =(l+r)/2;
        if(check(mid)) l=mid;
        else r=mid;
    }
    printf("%.0f\n",l*100);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值