HDU 4027 Can you answer these queries? 线段树 区间修改与查询

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 8122    Accepted Submission(s): 1845


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
 
 
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
 
 
Case #1: 19 7 6
 

Source

好的 这题我们怎么考虑 我们这样想 题目给的是1e6 你可以开平方根多次 你会发现次数不会超过7

那么是不是对我很多次修改操作 我都让他降到1了 他还会降吗? 不会 也就是说我们在更新的时候判断一下值是不是等于

r-l+1那么就可以节省很多时间 这题代码实现的时候出了点小问题 浪费了时间


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAX_N = 100024;
int n;
long long s[MAX_N*4];
void up(int p){
   s[p] = s[p*2]+s[p*2+1];
}
void build(int p,int l,int r){
    if(l==r){
        scanf("%lld",&s[p]);
    }
    else {
        int mid = (l+r)>>1;
        build(p*2,l,mid);
        build(p*2+1,mid+1,r);
        up(p);
    }
}
void change(int p,int l,int r,int x,int y){
    if(s[p]==r-l+1) return;
   if(l==r){
        s[p]=sqrt(1.0*s[p]);
        return;
    }
    int mid=(l+r)>>1;
    if(x<=mid) change(p*2,l,mid,x,y);
    if(y>mid) change(p*2+1,mid+1,r,x,y);
    up(p);
}
long long query(int p,int l,int r,int x,int y){
    if(x<=l&&r<=y){
        return s[p];
    }
    int mid = (l+r)>>1;
    long long res = 0;
    if(x<=mid) res+=query(p*2,l,mid,x,y);
    if(y>mid) res+=query(p*2+1,mid+1,r,x,y);
    return res;
}
int main(){
    int Case = 1,m;
    while(~scanf("%d",&n)){
      build(1,1,n);
      scanf("%d",&m);
      printf("Case #%d:\n",Case++);
      while(m--){
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(b>c){
            b=b+c;
            c=b-c;
            b=b-c;
        }
        if(a==0){
            change(1,1,n,b,c);
        }
        if(a==1){
            printf("%lld\n",query(1,1,n,b,c));
        }
      }
      printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值