UVA 455 Periodic Strings (水题)KMP小性质轻松过

今天遇到一个曾经过去的题 学了KMP以后 艾玛 这不是用下NEXT数组秒出吗

就重新过了一下 注意如果长度-Next[长度]不能被长度整除 那么就是整个是周期

A character string is said to have period k if it can be formed by concatenating one or more repetitionsof another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formedby 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (onerepetition of ”abcabcabcabc”).

  Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that yourprogram will test followed by a blank line. Each test case will contain a single character string of upto 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output areseparated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

详情见代码吧

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1e6+5;
    int Next[maxn];
    char mo[maxn];
    int n2;
    void GetNext()
    {
        int i=0,j=-1;
        while(i<n2)
        {
            if(j==-1||mo[i]==mo[j]) {++i,++j,Next[i]=j;}
            else j=Next[j];
        }
        return ;
    }

    int main()
    {
        int n;
        scanf("%d",&n);
        while(n--){
        scanf("%s",mo);
        n2=strlen(mo);
        Next[0]=-1;
        GetNext();
        if((n2%(n2-Next[n2]))!=0) printf("%d\n",n2);
        else printf("%d\n",n2-Next[n2]);
        if(n!=0) printf("\n")
        }
        return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值